Cisco Router and Switch Configuration: PPP, DHCP, VLAN, RIP, OSPF, EIGRP

Classified in Technology

Written at on English with a size of 4.33 KB.

Cisco Router and Switch Configuration

PPP Authentication

1. User Configuration (Matching Passwords on Both Routers)

router(config)# username <hostname_remote_router> password <password>

2. Interface Encapsulation Change

router(config-if)# encapsulation ppp

3.1 Enabling PAP Authentication

router(config-if)# encapsulation ppp
router(config-if)# ppp authentication pap
router(config-if)# ppp pap sent-username <local_username> password <password>

3.2 Enabling CHAP Authentication

router(config-if)# encapsulation ppp
router(config-if)# ppp authentication chap

DHCP Scope Configuration

router(config)# ip dhcp pool <POOL_NAME>
router(config-dhcp)# network <NETWORK_ADDRESS> <NETMASK>
router(config-dhcp)# default-router <GATEWAY_IP>
router(config-dhcp)# dns-server <DNS_SERVER_IP>
router(config-dhcp)# netbios-name-server <WINS_SERVER_IP>
router(config-dhcp)# domain-name <DOMAIN_NAME>

Address Exclusion

router(config)# ip dhcp excluded-address <START_IP> <END_IP>

VLAN Interface Association

Assigning Interfaces to VLANs

switch(config)# interface type x/y
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan <VLAN_ID>

Assigning a Range of Interfaces to a VLAN

switch(config)# interface range type x/y - z
(where x=Start Interface, y=End Interface)
switch(config-if-range)# switchport mode access
switch(config-if-range)# switchport access vlan <VLAN_ID>

Example

switch(config)# interface range fastEthernet 0/1 - 10
switch(config-if-range)# switchport mode access
switch(config-if-range)# switchport access vlan 10

Trunk Configuration

Trunk on a Switch

switch(config-if)# switchport mode trunk

Trunk on a Router

router(config)# interface fastethernet 0/0
router(config-if)# no shutdown
router(config-if)# interface fastEthernet 0/0.1
router(config-subif)# encapsulation dot1q <vlan_number>
router(config-subif)# ip address ...

RIP Configuration

router(config)# interface fastethernet 0/0
router(config-if)# ip address 192.168.50.129 255.255.255.192
router(config-if)# ip rip send version 1
router(config-if)# ip rip receive version 1
router(config)# interface fastethernet 0/1
router(config-if)# ip address 172.25.150.193 255.255.255.240
router(config-if)# ip rip send version 1 2

RIP Verification Commands

show ip protocols
show interface <interface>
show ip interface <interface>
show running-config
show ip rip database

OSPF Configuration

router(config)# router ospf <process-id>
router(config-router)# network <address> <wildcard-mask> area <area-id>
router(config)# interface loopback 0
router(config-if)# ip address 192.168.3.33 255.255.255.255
router(config-if)# bandwidth 64
router(config-if)# ip ospf cost 1562

OSPF Authentication

Without MD5

router(config-if)# ip ospf authentication-key <password>
router(config-router)# area <area-number> authentication

With MD5

router(config-if)# ip ospf message-digest-key <key-id> md5 <key>
router(config-router)# area <area-id> authentication message-digest

Other OSPF Configurations

router(config-if)# ip ospf hello-interval <seconds>
router(config-if)# ip ospf dead-interval <seconds>
debug ip ospf events
--Increase priority to elect a DR router
switch(config)# interface fastethernet 0/0
switch(config-if)# ip ospf priority 50

EIGRP Configuration

router(config)# router eigrp <as-id>
router(config-router)# network 192.168.3.0
router# show ip eigrp topology

EIGRP Additional Commands

eigrp log-neighbor-changes
Summarize routes: router(config-router)# no auto-summary

Entradas relacionadas: